Degraded Delivery to protonmail

Incident Report for InterServer

Identified

Protonmail status page indicates "Identified - We have identified a critical cooling failure in our Frankfurt datacenter. We are currently in the process of shifting traffic to our backups sites."
Posted Aug 26, 2026 - 19:08 EDT

Investigating

Protonmail is currently sending 'Recipient address rejected: Please try later' and appears that their service is degraded or partially offline. These emails are in queue and not currently delivering.
Posted Aug 26, 2026 - 19:06 EDT
This incident affects: Services (VPS).