storage-kvm3.lax

Incident Report for InterServer

Resolved

This incident has been resolved.
Posted May 20, 2026 - 19:09 EDT

Investigating

The storage-kvm3 server in the LAX datacenter is offline. Technicians are currently investigating the cause.
Posted May 20, 2026 - 11:37 EDT
This incident affected: Services (VPS).