my.interserver.net portal

Incident Report for InterServer

Resolved

This incident has been resolved.
Posted May 24, 2024 - 11:01 EDT

Investigating

The my.interserver.net portal will be offline to add in additional network capacity for its internal infrastructure. This change will not affect any services other than portal logins.
Posted May 24, 2024 - 10:20 EDT
This incident affected: my (Management Portal).