KVM367 Emergency Maintenance

Incident Report for InterServer

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 17:39 EST

Identified

The host node has encountered a critical hardware fault and must be taken offline for emergency maintenance. Our team is currently addressing the issue to restore normal operation as soon as possible.
Posted Nov 12, 2025 - 16:56 EST
This incident affected: Services (VPS).