Email delays to Outlook/Hotmail

Incident Report for InterServer

Update

Unfortunately email delays are still being seen. Further feedback from other mail operators continue to show similar errors affecting multiple different mail services.
Posted Feb 24, 2026 - 14:29 EST

Update

Emails to hotmail are delivering but some emails are delayed for a number of minutes.
Posted Feb 23, 2026 - 21:02 EST

Investigating

We are investigating email delays to outlook/hotmail domains, with 0365 domains unaffected. While information is limited on the scope of the problem, it appears to be a widespread issue.
Posted Feb 23, 2026 - 16:35 EST
This incident affects: Services (Mailbaby).